Author Topic: scoreboard bug & mapbug  (Read 1178 times)

0 Members and 1 Guest are viewing this topic.

Offline danmer

  • Camper
  • ***
  • Posts: 466
  • crabhead
scoreboard bug & mapbug
« on: December 12, 2008, 05:20:01 am »
There's this huge script im trying to work on, and it keeps acting really weird. After doing some stuff, the scoreboard suddenly feaks out and starts adding my kills to another player every other second (as if it was triggered in apponidle). Then, after the script goes to the initial state, i get all the points back. Seems like something in the script messes up the server in a funny way. It doesnt do this when i comment out the whole apponidle procedure, but still does it if i comment the code in it :-\
I cant really paste it all here, since the thing is quite big, and im not sure which part causes this. Just wanted to know if anyone has encountered this problem before.
I think the same event also causes a mapbug, which is when the server doesnt switch to the next map if its a custom map...


edit: retardation... Could someone please move this to script discussions, didnt mean to post this in releases
« Last Edit: December 12, 2008, 05:22:25 am by danmer »

Offline DorkeyDear

  • Veteran
  • *****
  • Posts: 1507
  • I also go by Curt or menturi
Re: scoreboard bug & mapbug
« Reply #1 on: December 12, 2008, 06:30:28 am »
If your using threads. try avoiding using of them. Some people have unexpected odd results with issues relating to that.
Possibly interaction with another script?? (I doubt, but make sure that when testing, it is the only script there)

Offline danmer

  • Camper
  • ***
  • Posts: 466
  • crabhead
Re: scoreboard bug & mapbug
« Reply #2 on: December 13, 2008, 06:37:48 am »
If your using threads. try avoiding using of them. Some people have unexpected odd results with issues relating to that.
Possibly interaction with another script?? (I doubt, but make sure that when testing, it is the only script there)

no, i dont use threads there. And i tried running only that script, didnt help

Offline Gizd

  • Flagrunner
  • ****
  • Posts: 586
  • (Re)tired
    • Eat-this! community site
Re: scoreboard bug & mapbug
« Reply #3 on: December 13, 2008, 09:46:21 am »
If you are talking about ZS, i know almost all bugs:
 - points are transfered to bots('Look at my stats!' is disabled)
 - ping of all players without you is 4250('Lag!' is disabled)
 - some bots have ping(it's ping of other players)(confusing)
ZS is master of this bug, but some other scripts have this problem too.

Offline danmer

  • Camper
  • ***
  • Posts: 466
  • crabhead
Re: scoreboard bug & mapbug
« Reply #4 on: December 13, 2008, 06:53:08 pm »
If you are talking about ZS, i know almost all bugs:
 - points are transfered to bots('Look at my stats!' is disabled)
 - ping of all players without you is 4250('Lag!' is disabled)
 - some bots have ping(it's ping of other players)(confusing)
ZS is master of this bug, but some other scripts have this problem too.
exactly that, but do you know what could be causing it?

Offline iDante

  • Veteran
  • *****
  • Posts: 1967
Re: scoreboard bug & mapbug
« Reply #5 on: December 13, 2008, 09:19:59 pm »
I may be missing something, but did you post the script here? Not much I can do without it.

Offline danmer

  • Camper
  • ***
  • Posts: 466
  • crabhead
Re: scoreboard bug & mapbug
« Reply #6 on: December 31, 2008, 06:54:30 am »
seemed to happen because of a bad bot file. Its secondary was "LAW" (should have been a number). Its quite queer, cause when i add that bot manually using console, or even with the script (with a custom command that dds the bot and does some extra stuff) it works fine. But when the script ads that bot through apponidle and kicks another bot at the same time, the scoreboard breaks, and the mapbug starts occuring.

As a side note, such "broken" bots behave like dummies on built-in soldat server (the one that comes with the client), but seem to run around and even shoot on the dedicated =P