Author Topic: Registering server...fail.  (Read 1438 times)

0 Members and 1 Guest are viewing this topic.

Offline Kisszuperman

  • Major(1)
  • Posts: 6
Registering server...fail.
« on: August 20, 2009, 03:25:22 pm »
Hello.

In the past few days I was trying to make a server but I couldn't due to several reasons.
I've read all these topics in this forum but I haven't seen any solutions... all response were "Port forward your router".
I did, and it's good and still nobody can't join my server. I'll post the configuration about my port forwarding later if you want so you can check that I missed something or not.

The second problem is that even if I make the server (registered but not dedicated), registering to server just fails and doesn't even appear on the lobby list.
Here is a picture about getting the message "Registering server @ ....... ip"

http://i419.photobucket.com/albums/pp275/Kisszuperman/euf7tmp.jpg

Any suggestions? [retard]

Offline Centurion

  • Flagrunner
  • ****
  • Posts: 699
Re: Registering server...fail.
« Reply #1 on: August 20, 2009, 03:49:41 pm »
You are using the wrong tools for hosting a server.

Offline Kisszuperman

  • Major(1)
  • Posts: 6
Re: Registering server...fail.
« Reply #2 on: August 20, 2009, 04:55:10 pm »
Wrong tools? :o
I don't even use anything. I just check the "Register in Lobby server" in the Options and thats all.

Offline croat1gamer

  • Veteran
  • *****
  • Posts: 1327
  • OMG CHANGING AVATAR!!! ^ω^
Re: Registering server...fail.
« Reply #3 on: August 20, 2009, 05:06:41 pm »
http://soldat.pl/en/download/soldatserver265.zip
Use this in a separate folder.
You connect to the server with the ip 127.0.0.1 and the port 23073.
You need to forward the ports 23073 and 23083 if you want that other players can join.

Then check with this http://server1.enesce.com/ptest.php if everything is correct.
If everything is properly made you should get this:

Code: [Select]
OK. Please wait while we test your server configuration... (This may take up to 2 minutes)
Checking IP Address validity... PASS!

Step One: Ingame Connectivity Test
(?) Sending PING test to <your ip> on UDP Port 23073... PASS! (<your ping>)
(?) Sending REQUEST test to <your ip> on UDP Port 28294... PASS!
(?) Sending JOIN GAME test to <your ip> on UDP Port 28294... PASS!
Step Two: All-Seeing Eye Test
(?) Sending test to <your ip> on UDP Port 23196... FAILED! (<your ping>)
Step Three: Remote Administration
(?) Sending test to <your ip> on TCP Port 28294... PASS!
Step Four: Map Download Connections
(?) Sending test to <your ip> on TCP Port 28304... PASS!

TEST RESULTS:
- Total Passed: 5/6
- UDP Check: check
- ASE Check: error
- Admin Check: check
- Download Check: check (Vital)
- Final Test Result: PASS!
[ Rent a Soldat Server ]
The ASE check doesnt matter, as you wont need it for personal usage.
Last year, I dreamt I was pissing at a restroom, but I missed the urinal and my penis exploded.

Offline Kisszuperman

  • Major(1)
  • Posts: 6
Re: Registering server...fail.
« Reply #4 on: August 20, 2009, 06:08:53 pm »
Eh everything failed. :s But I forwarded the ports right. Here is a picture of my configuration and the guide to forward soldat ports.

http://i419.photobucket.com/albums/pp275/Kisszuperman/forwardingport.png

Or I missed something?:\

Offline jrgp

  • Administrator
  • Flamebow Warrior
  • *****
  • Posts: 5018
Re: Registering server...fail.
« Reply #5 on: August 20, 2009, 07:02:06 pm »
You need to have the separate dedicated soldat server (as croat mentioned) running while you take the test.
Careful with that axe, Eugene.

Offline Kisszuperman

  • Major(1)
  • Posts: 6
Re: Registering server...fail.
« Reply #6 on: August 20, 2009, 07:13:20 pm »
Still
Code: [Select]
- Final Test Result: FAILED! Please check your network configuration.

Offline croat1gamer

  • Veteran
  • *****
  • Posts: 1327
  • OMG CHANGING AVATAR!!! ^ω^
Re: Registering server...fail.
« Reply #7 on: August 20, 2009, 07:21:43 pm »
Make screenshots of the folder where you placed the dedicated server i gave you link to, to make sure that you didnt do something wrong.
Last year, I dreamt I was pissing at a restroom, but I missed the urinal and my penis exploded.

Offline Kisszuperman

  • Major(1)
  • Posts: 6

Offline croat1gamer

  • Veteran
  • *****
  • Posts: 1327
  • OMG CHANGING AVATAR!!! ^ω^
Re: Registering server...fail.
« Reply #9 on: August 21, 2009, 08:49:35 am »
You are starting it from Soldat server 2.6.5, right?
Last year, I dreamt I was pissing at a restroom, but I missed the urinal and my penis exploded.

Offline Kisszuperman

  • Major(1)
  • Posts: 6
Re: Registering server...fail.
« Reply #10 on: August 28, 2009, 11:05:32 am »
Good and bad news. After trying different ways to configure my port settings I've managed to open the TCP ports and 2 out of 6 were "Pass" of the test.
Code: [Select]
Step Three: Remote Administration
(?) Sending test to xxxxxxxxxxxx on TCP Port 23073... PASS!
Step Four: Map Download Connections
(?) Sending test to xxxxxxxxxxxx on TCP Port 23083... PASS!

But the UDP ports are still closed don't know why. :\

Code: [Select]
(?) Sending PING test to xxxxxxxxxx on UDP Port 23073... FAILED!
(?) Sending REQUEST test to xxxxxxxxxx on UDP Port 23073... FAILED!
(?) Sending JOIN GAME test to xxxxxxxxxx on UDP Port 23073... FAILED!

Any suggestions about forwarding UDP ports?

Offline VinceBros

  • Soldat Beta Team
  • Camper
  • ******
  • Posts: 275
Re: Registering server...fail.
« Reply #11 on: August 28, 2009, 12:14:30 pm »
Did you go on PortForward.Com ?

Maybe you Forwarded TCP ports only. On this website, you will be able to find out how to forward your ports. Just choose your router in the list.

http://www.portforward.com/english/applications/port_forwarding/Soldat/Soldatindex.htm

Cheers.