Author Topic: Desura failed update version 1.6.2-1.6.3  (Read 2179 times)

0 Members and 1 Guest are viewing this topic.

Offline yayfrog

  • Major(1)
  • Posts: 18
Desura failed update version 1.6.2-1.6.3
« on: June 03, 2012, 04:17:46 pm »
I prefer playing Soldat through Desura to keep things organized but the Desura version of Soldat is out of date.
It is currently 1.6.1. I can download the update to go from 1.6.1-1.6.2 and it updates the game fine but the 1.6.2-.1.6.3 update does says 'setup could not locate a compatable version of Soldat. Update Failed!'.

The Soldat folder is C:\Program Files\Desura\Common\Soldat. Since it works for 1.6.2 but not 1.6.3 I don't really know what could be wrong.
I really would be nice if Soldat was up to date on Desura and used their update feature but that's unrelated and not going to happen.

I just reinstalled Soldat I don't remember how I got around this before. I might have just used my old install in C:\Soldat and stopped using the Desura version after 1.6.2 but I do know I was playing 1.6.3 on my computer before.

Thanks for any help.

Offline Shoozza

  • Retired Soldat Developer
  • Veteran
  • ******
  • Posts: 1631
  • Soldat's Babysitter
    • Website
Re: Desura failed update version 1.6.2-1.6.3
« Reply #1 on: June 10, 2012, 12:36:29 am »
Thanks for the info.
I guess I'll have to create a new installer for 1.6.3 once I finally got the time for it.
Rules
Tools: ARSSE - SARS - SRB - chatMod

Offline yayfrog

  • Major(1)
  • Posts: 18
Re: Desura failed update version 1.6.2-1.6.3
« Reply #2 on: June 10, 2012, 04:02:24 pm »
Cool beans and thanks.
I did find out though that there is a sizable enough community of people playing 1.6.2 that it can sustain a DM match on Ash pretty much constantly.
I talked to a few of the people playing 1.6.2 and they all said they were aware that 1.6.2 was not the newest version but didn't give a reason for why they hadn't updated.

I'm certainly going to start keeping old versions of Soldat installed on my computer maybe there are still people playing 1.4.

I'll also try to see if I have this problem on other computers running Desura just in case.

Offline Shard

  • Camper
  • ***
  • Posts: 449
  • yeet
Re: Desura failed update version 1.6.2-1.6.3
« Reply #3 on: June 13, 2012, 11:46:49 am »
I have this problem and I'm not running Soldat through Desura, tried repeatedly updating it to 1.6.2, 1.6.3 updater just wont work.

Offline Shoozza

  • Retired Soldat Developer
  • Veteran
  • ******
  • Posts: 1631
  • Soldat's Babysitter
    • Website
Re: Desura failed update version 1.6.2-1.6.3
« Reply #4 on: June 14, 2012, 03:26:56 am »
I have this problem and I'm not running Soldat through Desura, tried repeatedly updating it to 1.6.2, 1.6.3 updater just wont work.
Yeah sadly updating wont work unless you installed soldat 1.6.2 full.
If you updated from older versions it fails to find them (I forgot that the patches used some weird ids thats why).
Rules
Tools: ARSSE - SARS - SRB - chatMod

Offline punkee

  • Major(1)
  • Posts: 2
Re: Desura failed update version 1.6.2-1.6.3
« Reply #5 on: October 22, 2020, 03:21:39 pm »
Sorry to bringing up the old thread, but I also have this problem.
I dig up my old laptop and started Soldat after many years, so I had 1.5 version of the game (registered).
Manage to patch the game to 1.6.2, but have same error for patching to 1.6.3

How to solve that ? Can I just patch to 1.6.4 or even newest 1.7.1 version without loosing my registration and data from the game ?

Thanks!


Offline punkee

  • Major(1)
  • Posts: 2
Re: Desura failed update version 1.6.2-1.6.3
« Reply #6 on: October 23, 2020, 07:17:28 am »
Menaged to instal 1.6.2 without loosing registration data (just made install in separate folder) and patched from fresh install.
Altought last version which I can play is 1.6.9 because graphic card on my old laptop support only Open GL 1.5 :(

To bad, because there is no online servers with version 1.6.9...