Author Topic: Server crash after start ("" is an invalid integer)  (Read 894 times)

0 Members and 1 Guest are viewing this topic.

Offline kicikici

  • Soldier
  • **
  • Posts: 177
Server crash after start ("" is an invalid integer)
« on: January 17, 2016, 02:45:15 am »
I have restarted one of my servers today. Now I am still getting this bug. Everything was fine until that restart.

Code: [Select]
             -= Soldat Dedicated Server 1.6.9 - 2.7.8 =-

----------------------------------------------------------------
         Soldat Dedicated Server initializing...
----------------------------------------------------------------

   Need help running your server?
   IRC: #soldat.devs @ irc.quakenet.org

   ---> http://soldatforums.com/

   Additional parameters:
   ./soldatserver -p PORT -l MAXPLAYERS -k PASSWORD
   Example: ./soldatserver -p 23073 -l 16 -k "my pass"


 Compiled with FreePascal (Indy 10)

Server Encountered an error:
"" is an invalid integer
Shutting down server...
Shutting down admin server...

Any ideas? Probably deleting all files and setting everything from start will solve this problem but maybe someone knows something about it.
Classic banana

Offline darDar

  • Soldat Beta Team
  • Flagrunner
  • ******
  • Posts: 781
  • 2004 - 2016
    • #Soldat Gather - Community on Discord
Re: Server crash after start ("" is an invalid integer)
« Reply #1 on: January 17, 2016, 07:29:26 am »
Maybe there is something missing? e.g; in the soldat.ini? empty adminlog = "" ?

| My Maps: ctf_Pyramid, ctf_Replay, ctf_Blako, ctf_R6, ctf_Ntex, ctf_Caro, ctf_Bizar & vs_mode mappack |

Offline darDar

  • Soldat Beta Team
  • Flagrunner
  • ******
  • Posts: 781
  • 2004 - 2016
    • #Soldat Gather - Community on Discord
Re: Server crash after start ("" is an invalid integer)
« Reply #2 on: January 17, 2016, 08:41:49 am »
Server Encountered an error:
"" is an invalid integer
Shutting down server...
Shutting down admin server...

Well, I get the same now.

Edit1: scripting = 0 will fix this.
Edit2: scripting = 1 works again.

just change scripting to off and on again and restart, worked for me.
« Last Edit: January 17, 2016, 08:53:27 am by darDar »

| My Maps: ctf_Pyramid, ctf_Replay, ctf_Blako, ctf_R6, ctf_Ntex, ctf_Caro, ctf_Bizar & vs_mode mappack |

Offline KoGAi

  • Major(1)
  • Posts: 30
  • The Light of the Universe
Re: Server crash after start ("" is an invalid integer)
« Reply #3 on: August 24, 2017, 02:29:13 pm »
We're getting the same thing, however nothing has changed recently. It happens so sporadically, even when the servers are empty, that it's either the entire server itself or some kind of server bug being exploited.
=₳US7RAL|¹² is a growing Soldat Community making a difference by offering a wide variety of top-notch servers across North America- a new alternative to everyone.
Jump into our servers in NA with the new domain (austral12.com)! Check our Facebook Page.
_______
#austral12soldat @ QuakeNet ▲ facebook.com/AUS7RAL12 ▲ twitter.com/AUS7RAL12

Offline You Got Served!

  • Major(1)
  • Posts: 26
Re: Server crash after start ("" is an invalid integer)
« Reply #4 on: August 24, 2017, 03:12:03 pm »
[!] Update

Can confirm, the kid is at it again.

He gets bored after a while.

Server Encountered an error:
"" is an invalid integer

Every 10 minutes or so.. for 2.5 hours =D

I have cycled scripts on & off and checked .ini files.

I need backup!
« Last Edit: August 24, 2017, 06:11:52 pm by You Got Served! »

Offline Hubiq

  • Major
  • *
  • Posts: 95
Re: Server crash after start ("" is an invalid integer)
« Reply #5 on: August 24, 2017, 05:17:14 pm »
Today 30 servers have disappeared. Probably this error is the cause  :|

Offline KoGAi

  • Major(1)
  • Posts: 30
  • The Light of the Universe
Re: Server crash after start ("" is an invalid integer)
« Reply #6 on: August 24, 2017, 07:02:28 pm »
Yep, it first started around 9:30 AM US ET, which means it must be an unemployed individual, most likely under-aged with loads of time at hand.
We would appreciate any feedback from the developers to perhaps issue a permanent fix or advise on how to prevent it from happening. I know there are new communities out there with inexperienced server admins that may succumb to this more than others.
=₳US7RAL|¹² is a growing Soldat Community making a difference by offering a wide variety of top-notch servers across North America- a new alternative to everyone.
Jump into our servers in NA with the new domain (austral12.com)! Check our Facebook Page.
_______
#austral12soldat @ QuakeNet ▲ facebook.com/AUS7RAL12 ▲ twitter.com/AUS7RAL12

Offline Hubiq

  • Major
  • *
  • Posts: 95
Re: Server crash after start ("" is an invalid integer)
« Reply #7 on: August 25, 2017, 12:38:54 pm »
This bug totally destroys the game. And developers? They have it in their ass.

Offline Petterkowski

  • Soldat Beta Team
  • Major
  • ******
  • Posts: 87
Re: Server crash after start ("" is an invalid integer)
« Reply #8 on: August 25, 2017, 12:45:49 pm »
Servers are still disconnecting. Let's just hope it's going to be taken care of asap :]


Once more into the fray...
Into the last good fight I'll ever know.
Live and die on this day...
Live and die on this day...

Offline Shoozza

  • Soldat Developer
  • Veteran
  • ******
  • Posts: 1599
  • Soldat's Babysitter
    • Website
Re: Server crash after start ("" is an invalid integer)
« Reply #9 on: August 26, 2017, 02:33:39 am »
A few things that might help the devs to quickly figure out what is causing the bug:

Does it happen on windows or linux or mac servers (or some/all of them)?
Are there patterns when this bug happens more often (game modes, scripting on/off, player count, etc, soldat.ini/server.ini for comparisson (don't forget to remove admin passwords before uploading))?
Also log files could come in handy (again make sure to remove passwords if someone wrote it in chat).

Thanks ;)
Rules
Tools: ARSSE - SARS - SRB - chatMod

Offline kicikici

  • Soldier
  • **
  • Posts: 177
Re: Server crash after start ("" is an invalid integer)
« Reply #10 on: August 26, 2017, 04:20:00 am »
IMO someone is messing with ip/hwid. Recently I had a hacker who have tried crash my servers using repeatedly login as tcp admin using bad password. Maybe he found better way?

From logs, I saw something like this (lack of hwid):
17-08-13 11:08:08 78.166.250.30:23073| requesting game...
17-08-13 11:08:14 78.166.250.30:23073| requesting game...

Yesterday, I realized that one of my servers wont start after few invalid integers crashes. After investigating, I found banned ip in banned.txt which looked like xxx.xxx.xxx.xxx:23073)
No idea why that ip contained ":23073)".
Classic banana

Offline Shoozza

  • Soldat Developer
  • Veteran
  • ******
  • Posts: 1599
  • Soldat's Babysitter
    • Website
Re: Server crash after start ("" is an invalid integer)
« Reply #11 on: August 26, 2017, 05:20:45 am »
What did you do to get it back up?
I just checked and if the banned.txt or bannedhw.txt contain invalid text (not numbers) the "" is not an valid integer number will happen.
Does the server still crash for you?
If so can you check if it starts if you use a clean banned.txt and bannedhw.txt?
Rules
Tools: ARSSE - SARS - SRB - chatMod

Offline kicikici

  • Soldier
  • **
  • Posts: 177
Re: Server crash after start ("" is an invalid integer)
« Reply #12 on: August 26, 2017, 06:47:11 am »
Yes, I just cleaned these txt's. Server works normally now.
Classic banana

Offline Hubiq

  • Major
  • *
  • Posts: 95
Re: Server crash after start ("" is an invalid integer)
« Reply #13 on: August 26, 2017, 07:41:25 am »
Starts again... I played on 3 public servers (10 minutes ago) and each server has been disabled.
« Last Edit: August 26, 2017, 07:43:46 am by Hubiq »

Offline KoGAi

  • Major(1)
  • Posts: 30
  • The Light of the Universe
Re: Server crash after start ("" is an invalid integer)
« Reply #14 on: August 26, 2017, 09:31:23 am »
Well, that may be true, however servers that have no data inside those files will also be disabled. Our servers turn themselves on automatically so it isn't any more pernicious than that. It is still surprising that the issue was reported almost 2 years ago and there hasn't been an official feedback from the developers or a fix. The servers do not get anything logged other than the errors, and it seems to be happening for Linux users as well.
=₳US7RAL|¹² is a growing Soldat Community making a difference by offering a wide variety of top-notch servers across North America- a new alternative to everyone.
Jump into our servers in NA with the new domain (austral12.com)! Check our Facebook Page.
_______
#austral12soldat @ QuakeNet ▲ facebook.com/AUS7RAL12 ▲ twitter.com/AUS7RAL12

Offline Shoozza

  • Soldat Developer
  • Veteran
  • ******
  • Posts: 1599
  • Soldat's Babysitter
    • Website
Re: Server crash after start ("" is an invalid integer)
« Reply #15 on: August 26, 2017, 03:24:39 pm »
If someone has these issues (and can update soldatserver + test it) please contact me (pm here or better on discord) and I'll see if we can figure out what's the reason for it.
Rules
Tools: ARSSE - SARS - SRB - chatMod

Offline skrX

  • Soldier
  • **
  • Posts: 112
  • x ye.
Re: Server crash after start ("" is an invalid integer)
« Reply #16 on: August 26, 2017, 04:28:36 pm »
I had the same thing, every now and then the server loses connection

host: gshost.us

Offline soldat-game

  • Camper
  • ***
  • Posts: 273
  • GG: 10210041
Re: Server crash after start ("" is an invalid integer)
« Reply #17 on: August 26, 2017, 05:12:00 pm »
Oh no others also have discovered how to change HWID :( Shoozza you maybe implemented functions for hacked servers knowing your hacking history 1.5.0 :))

Offline jrgp

  • Administrator
  • Flamebow Warrior
  • *****
  • Posts: 4959
Re: Server crash after start ("" is an invalid integer)
« Reply #18 on: August 27, 2017, 02:50:02 pm »
I had the same thing, every now and then the server loses connection

host: gshost.us

I just implemented the tweak per https://forums.soldat.pl/index.php?topic=44957.0 on all my soldat servers in my EU region. If your server is there maybe that fix will help you. Let me know which server is yours (maybe PM me) and I can dig deeper for you.
Playing Soldat and active on these forums from 2004 - present

Offline You Got Served!

  • Major(1)
  • Posts: 26
Re: Server crash after start ("" is an invalid integer)
« Reply #19 on: August 27, 2017, 03:31:26 pm »
Great work.

Thanks to Helloer, Moroes & jrgp

You guys are K!ngs <3