Author Topic: Can't run game with dedicated nvidia gpu  (Read 4780 times)

0 Members and 1 Guest are viewing this topic.

Offline deguix

  • Major
  • *
  • Posts: 79
Re: Can't run game with dedicated nvidia gpu
« Reply #20 on: February 23, 2016, 10:55:43 am »
Quote
err:winediag:schan_imp_init Failed to load libgnutls, secure connections will not be available.
Another dependency is missing here. Get lib32-gnutls.

If you use optirun by itself, then you need lib32-virtualgl (because it uses virtualgl bridge), it's usually slower than using optirun -b primus...

---

I used to use ubuntu it until it started bugging from just updating. It crashed more than Windows. Then I went Manjaro, and it was working fine but there were some very hard problems that couldn't be solved without having to read on arch linux itself (which broke the Manjaro's scripts if you weren't very careful), and also it doesn't get updated as often. So I just went to arch linux. The installation/setup was very frustrating and time-consuming, but once you get it working, then it becomes amazing.
« Last Edit: February 23, 2016, 11:08:39 am by deguix »

Offline CCalp

  • Global Moderator
  • Soldier
  • *****
  • Posts: 235
  • calp (SN)
Re: Can't run game with dedicated nvidia gpu
« Reply #21 on: February 24, 2016, 09:13:18 pm »
from arch wiki -> https://wiki.archlinux.org/index.php/bumblebee#Installation

ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored
You probably want to start a 32-bit application with bumblebee on a 64-bit system. See the "For 32-bit..." section in #Installation. If the problem persists or if it is a 64-bit application, try using the primus bridge.

I already tried that.
I guess I'll give up (for now). In the end it's not really important, since I still get ~120 FPS with my internal gpu. Just would have been cool to get that working :p

Switching the distro is not really an option for me - except for Arch. I was both on Ubuntu and Mint for about a year each, and despite I actually liked the user experience they gave me, I want to avoid Ubuntu and its derivates for privacy and personal reasons. I tried out Debian, but I didn't like it as much as Arch / Manjaro. I would have gone to Arch, but that seemed to be too complicated for me still. I'm sure I'll go there one day, enjoying Manjaro as a good step towards Arch. :-)

Anyway guys, thank you for your help. I really appreciate it.
If someone has any other idea (sometime) I will be happy to tried it out!

Cheers

Offline Rattle.Head

  • Major(1)
  • Posts: 35
  • || sk!T ||
Re: Can't run game with dedicated nvidia gpu
« Reply #22 on: September 25, 2018, 07:43:55 pm »
did you solve this? want to go back and can't fix it. My internal gpu shows black screen too

Offline Rattle.Head

  • Major(1)
  • Posts: 35
  • || sk!T ||
Re: Can't run game with dedicated nvidia gpu
« Reply #23 on: October 26, 2018, 07:10:03 pm »
I mannage to run it

Offline CCalp

  • Global Moderator
  • Soldier
  • *****
  • Posts: 235
  • calp (SN)
Re: Can't run game with dedicated nvidia gpu
« Reply #24 on: October 29, 2018, 07:06:03 am »
I mannage to run it

Nice! Do you mind sharing your solution for other players, too?