Author Topic: Soldat on Linux & OS X Systems  (Read 156097 times)

0 Members and 1 Guest are viewing this topic.

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #100 on: December 06, 2006, 07:25:20 am »
Uh, well, the WINE binary should be in /usr/bin or something. If you mean the .wine folder that keeps your fake C drive and such, hit Ctrl-H while in your home folder to see those hidden .name folders...
Soldat on Linux: It does work! Need help?

Offline Krillious

  • Camper
  • ***
  • Posts: 324
  • If you were a hindu I could aim for the dot
Re: Soldat on Linux Systems
« Reply #101 on: December 06, 2006, 07:45:09 am »
I think there is no wine directory you just download an exe and run it and wine just pops up on its own (if you have it installed)

Offline Frenchie

  • Camper
  • ***
  • Posts: 358
  • SoldatHQ
Re: Soldat on Linux Systems
« Reply #102 on: December 06, 2006, 08:17:36 am »
I think there is no wine directory you just download an exe and run it and wine just pops up on its own (if you have it installed)
Wow, thats just crap.
Right above your post is Stealth's response which answers The Bone Collector's question perfectly.

Yet your response makes no sense at all.
Soldat Lobby Avec Players -New Release! - Updated AGAIN!


Offline Krillious

  • Camper
  • ***
  • Posts: 324
  • If you were a hindu I could aim for the dot
Re: Soldat on Linux Systems
« Reply #103 on: December 09, 2006, 07:26:46 am »
oh i didn't see it i just saw the other guys post
and i what i meant is that when i installed wine it never gave me any settings it was just 'downloaded' and whenever i run an exe it opens as though i had windows

Offline Frenchie

  • Camper
  • ***
  • Posts: 358
  • SoldatHQ
Re: Soldat on Linux Systems
« Reply #104 on: December 10, 2006, 06:27:11 am »
Ah ok,
you can access wine settings by typing 'winecfg' into a terminal.
Soldat Lobby Avec Players -New Release! - Updated AGAIN!


Offline truup

  • Soldier
  • **
  • Posts: 243
Re: Soldat on Linux Systems
« Reply #105 on: December 17, 2006, 11:54:47 am »
Hey, nice topic you got here.
Im getting this weird error when I try to run Soldat:

"Cannot change Visible in OnShow or OnHide."

I guess they're somekind of events in code :? Check the screen ;o

Offline Frenchie

  • Camper
  • ***
  • Posts: 358
  • SoldatHQ
Re: Soldat on Linux Systems
« Reply #106 on: December 17, 2006, 05:49:04 pm »
I don't know what's causing that popup, maybe Stealth will. ;)

But that soldat screen looks exactly like mine when I haven't changed the audio output of wine. Try typing 'winecfg' into terminal and then going to Audio, and changing the device to ALSA. It's worth a shot.
Soldat Lobby Avec Players -New Release! - Updated AGAIN!


Offline FliesLikeABrick

  • Administrator
  • Flamebow Warrior
  • *****
  • Posts: 6142
    • Ultimate 13 Soldat
Re: Soldat on Linux Systems
« Reply #107 on: December 17, 2006, 06:02:30 pm »
Quote
My guess is because FAT32/NTFS are case-insensitive filesystems, WINE was confused on which directory to save the maps to and silently failed.

Actually, I believe it's just Windows (not the filesystem) that is case-insensitive. As I have a driver for reading ext3 from Windows, and it doesn't really care. Same vice-versa, with NTFS drivers, Linux is still case-sensitive on files on those partitions...

Right, but if Soldat is written for windows and windows never has two folders with the same "name" (eg maps and Maps), it makes sense that it may crash when it sees "Maps" and "maps".

Offline jettlarue

  • Flagrunner
  • ****
  • Posts: 724
Re: Soldat on Linux Systems
« Reply #108 on: December 17, 2006, 06:09:11 pm »
Quote
My guess is because FAT32/NTFS are case-insensitive filesystems, WINE was confused on which directory to save the maps to and silently failed.

Actually, I believe it's just Windows (not the filesystem) that is case-insensitive. As I have a driver for reading ext3 from Windows, and it doesn't really care. Same vice-versa, with NTFS drivers, Linux is still case-sensitive on files on those partitions...

Right, but if Soldat is written for windows and windows never has two folders with the same "name" (eg maps and Maps), it makes sense that it may crash when it sees "Maps" and "maps".
I had this problem, I fixed it by changing some various settings(can't remember) and rebooting.

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #109 on: December 17, 2006, 07:55:26 pm »
Yea Frenchie, from what I've seen, almost any error message that pops up in Soldat is due to a sound thing. You can try what Frenchie said, running "winecfg" go into the Audio tab, and select ALSA as your output. If that doesn't work, try using Soldat's installed Config tool "wine 'C:/Soldat/Soldat/Config.exe' ", then go into the Sound tab. Switch the Sound Drivers, and if neither of em work, then use the "NoSound" option in there. That usually works...
Soldat on Linux: It does work! Need help?

Offline truup

  • Soldier
  • **
  • Posts: 243
Re: Soldat on Linux Systems
« Reply #110 on: December 18, 2006, 10:29:26 am »
Thanks, selecting ALSA as my output worked \o/ And I managed to get my FPS to around 70! Now need to fix textures anymore, I hope I can find it in this topic :U

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #111 on: December 24, 2006, 03:22:58 pm »
What's wrong with the textures? Make sure you have the latest version of Wine!

Date Posted: December 19, 2006, 04:47:10 PM
Oooh...the newest version (0.9.28) came out today, look at these  fixes..

Quote
- OpenGL in child windows should work again.
  - Better mouse support in games.
  - Beginnings of new state management in Direct3D.
  - Improved audio and font support on Mac OS.
  - Lots of bug fixes.

Those 2 seem like they'd affect soldat (right now I'm having that same problem where my mouse isn't working), post up your experiences once you've got it!
Soldat on Linux: It does work! Need help?

Offline Frenchie

  • Camper
  • ***
  • Posts: 358
  • SoldatHQ
Re: Soldat on Linux Systems
« Reply #112 on: January 03, 2007, 07:46:19 pm »
Just tested it out.
Odd my mouse works but my keyboard doesn't work at all.  :-\
Soldat Lobby Avec Players -New Release! - Updated AGAIN!


Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #113 on: January 05, 2007, 03:42:53 pm »
Hmm, well, I borked my Ubuntu install (once again) but once I get it set back up (plan a full reformat of the drive, and should have WinXP, Mac OSX86 , and Ubuntu running) I'll be able to give results on it... ::)
Soldat on Linux: It does work! Need help?

Offline MtheF

  • Major(1)
  • Posts: 1
Re: Soldat on Linux Systems
« Reply #114 on: January 08, 2007, 07:17:02 am »
I've got Soldat running on debian Etch (testing).

My problems:

Input-problem. Mouse and keyboard didn't work in game.
To fix it i ran wineprefixcreate.
I still can't customize inputs but that is ok for me.

Classical text problem. Fixed by replacing fonts with FreeType.
Code: [Select]
cd [gamedir]
cp /var/lib/defoma/gs.d/dirs/fonts/FreeSans.ttf lucon.ttf
cp /var/lib/defoma/gs.d/dirs/fonts/FreeSans.ttf bgothl.ttf

Fullscreen composite(transparency, shadows) problem.
Setting wine to run in a window (800x600) and Soldat to run in fullscreen
works for me, even with composite on (I use xfce).

Nice gameĀ  ;)
/MtheF

Offline Frenchie

  • Camper
  • ***
  • Posts: 358
  • SoldatHQ
Re: Soldat on Linux Systems
« Reply #115 on: January 08, 2007, 04:15:48 pm »
Wow awesome, thats such an easy fix to get readable text. Good work.  ;D

But I still can't get my keyboard working. Even after trying wineprefixcreate.  :(

Edit. I tried running wine in 800 x 600 (emulated desktop) with soldat fullscreen and the keyboard works. Except there's an error when exiting game it just restarts level.
So I tried running soldat in 800 x 600 and keyboard works also.  :D

Weird it just doesn't work in fullscreen for me. (or maybe my comps too slow)
« Last Edit: January 08, 2007, 04:31:46 pm by Frenchie »
Soldat Lobby Avec Players -New Release! - Updated AGAIN!


Offline freidrichen

  • Major(1)
  • Posts: 1
Re: Soldat on Linux Systems
« Reply #116 on: January 09, 2007, 10:26:57 am »
I just installed Soldat on my gentoo box and (like most people do, it seems) i got that garbled text bug.
MtheF's solution worked very well. After a quick
Code: [Select]
find / -iname freesans.ttfi found FreeSans.ttf font and could copy it to my soldat folder.

Thanks a bunch!

Oh, also I couldn't configure my keyboard settings ingame so i had to manually edit soldat.ini, which is where the game keeps all such settings.

//Freidrichen

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #117 on: January 10, 2007, 05:57:13 pm »
Great info MtheF! I'll add it to the Wine App database...:)
Soldat on Linux: It does work! Need help?

Offline Landle

  • Major(1)
  • Posts: 7
Re: Soldat on Linux Systems
« Reply #118 on: January 21, 2007, 02:26:07 pm »
Ok, I will join you guys in this conversation.

Ok, It seems using a intel(r) controller like I have posted in my topic in the lounge makes the screen smaller. Let me elaborate...When I started up soldat the edges of the windows were black and I only have a small soldat screen like ditherlas(I think thats what it is called). And I tried Force Software. And tried to make it Capatible. But it seems it doesn't work.
Soldat shall rise in flying colors.()()
()()()()()()()()()()()()()()()()()()()()()

I don't have a sig yet.()
()()()()()()()()()()()()())()

Offline ds dude

  • Soldat Beta Team
  • Flagrunner
  • ******
  • Posts: 631
  • Lolicon Forever.
Re: Soldat on Linux Systems
« Reply #119 on: January 21, 2007, 08:21:18 pm »

Oops..That had nothing to do with Linux and soldat..I apologize.

Now
ive read all this and it came to my conclusion that soldat only works on Wine 0.9,yes?
I would love to participate in this event. Shall I see some other wine version such as 0.9 26? or 0.9 25 and see if it works?
This signature was borked. Now it is not.