Author Topic: Soldat on Linux & OS X Systems  (Read 171417 times)

0 Members and 1 Guest are viewing this topic.

Offline Skiessi

  • Major(1)
  • Posts: 41
    • asd.
Re: Soldat on Linux Systems
« Reply #180 on: April 30, 2007, 11:38:53 am »
Works perfectly.

I recommend GLSL + Video compability enabled

EDIT:
Btw, in 1.4.2 I can't play at all thanks to Michal's new 'hacking' prevention system.. I prefer playing with some random hackers around.
« Last Edit: November 24, 2007, 05:14:16 pm by Skiessi »

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #181 on: April 30, 2007, 11:58:50 am »
Yup, looks like it was beryl that caused the crash.

Checking video compatibility in the Soldat Config fixes the strange text blending, now it looks clean.
Soldat on Linux: It does work! Need help?

Offline wumpus

  • Major(1)
  • Posts: 9
Re: Soldat on Linux Systems
« Reply #182 on: April 30, 2007, 02:02:43 pm »
hey guys,

I have 1.4 running perfect here (ubuntu feisty) but I would appreciate more fps than ~45 in a 16 player game. On XP it works smoothly. I've dropped all settings from config.exe/.ini to minimum already (I dont mind the poor graphics). Resolution is the smallest too. You know any other tricks?

thanks for all who made windows totally obsolete today.

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #183 on: April 30, 2007, 08:43:49 pm »
I haven't tried it yet, but maybe if you enable GLSL mode it could speed things up.

Run regedit
Go to HKEY_CURRENT_USER/Software/Wine/Direct3D
Create a new string key called "UseGLSL"
Edit its value to "enabled"
Soldat on Linux: It does work! Need help?

Offline n2j3

  • Soldier
  • **
  • Posts: 152
    • soldat.gr
Re: Soldat on Linux Systems
« Reply #184 on: May 01, 2007, 10:48:56 pm »
Ok, tested it with Wine 0.9.36 and Beryl, works fine , jumpy fps (65 to 130 - on windows i get 63-64fps). Thanks for the Winedebug info Stealth :D

Offline sqweek

  • Major(1)
  • Posts: 13
Re: Soldat on Linux Systems
« Reply #185 on: May 02, 2007, 09:52:01 am »
Video Compat for the win. Thanks.

Offline blind

  • Major(1)
  • Posts: 1
Re: Soldat on Linux Systems
« Reply #186 on: May 14, 2007, 02:34:25 am »
I've enabled Video Compatibility (or, what I was assuming was video compat. "Compatibility" under "Graphics") but I still get the "OnShow,OnHide" message as well as the access violation ones and cannot play the game.

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #187 on: May 14, 2007, 12:30:02 pm »
blind, make sure you choose ALSA (and only ALSA) as your main option in the Sound tab under winecfg (run in terminal).
Soldat on Linux: It does work! Need help?

Offline jswm4xf0r7

  • Major(1)
  • Posts: 5
Re: Soldat on Linux Systems
« Reply #188 on: May 20, 2007, 11:42:53 am »
I run Soldat in Wine in Ubuntu, but fps is very low (impossible to aim the enemy). What to do next to the tricks mentioned on this thread. Tremulous works in ~ 90 FPS for me.
« Last Edit: May 20, 2007, 12:22:42 pm by jswm4xf0r7 »

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #189 on: May 23, 2007, 06:48:39 am »
Well, I would tell you to check the AppDB entry on the WINE site, but looks like some dude DELETED Soldat completely off the thing. Not only that, but the other game I maintained, battlefield 2, was deleted as well!! All that hard work...:(
Soldat on Linux: It does work! Need help?

Offline akiross

  • Major(1)
  • Posts: 4
Re: Soldat on Linux Systems
« Reply #190 on: May 23, 2007, 11:10:20 am »
Hi there
I just installed Soldat 1.3.1 (i don't like 1.4 graphics at all :P) on wine 0.9.37 on Gentoo, but i got some troubles for configuring controls (and since i don't have windows at all, i can't copy a valid configuration).

I tried to modify the configuration by hand (.ini file)... Seems that codes are given in a strange fashon:
tab = 15
q = 16
w = 17
...
a = 31
s = 32
d = 33
...
seems like a keyboard ordering here :D I don't know how the game works, so maybe it's the DX way to encode keys.

Mouse buttons seems to be mapped as mb0 (left click), mb1 (right), mb2 (center).

Now, I can do my configuration in this way, but there is something that i can't try: what about mouse wheel up and down?

Well, more generally the question is: if someone has the ability to change his keyboard configuration (maybe with a windows installation), could he post here the codes, please?
It's just a matter of creating a new profile and change the buttons, looking for the profile's .ini file and see under [CONTROL].

It would be really userful, until the bug is fixed with wine...

Thanks!

6th_account

  • Guest
Re: Soldat on Linux Systems
« Reply #191 on: May 23, 2007, 12:26:07 pm »
mouse wheel is "mw", if that's what you were asking :Q

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #192 on: May 24, 2007, 09:14:47 am »
akiross: I found the section in the HOWTO (on the WINE AppDB) about that, here's what it said:

The interface for setting controls is glitchy - you click on the button
and sometimes where it would normally ask you to press a key it just
says 'Key OK'. However, you can edit the [CONTROLS] section of
soldat.ini - you need to enter scancodes. But not actual scancodes...

They must go through a level of translation through linux/wine or this
section wouldn't be so complicated. There's a nice image of scancodes
at barcodeman.com BUT you need to subtract 1 from those numbers, or 2 for the bottom row. Eg, I have 'e'
as right, 'o' as crouch and ',' as jump, so I put 'Right=18',
'Crouch=24' and 'Jump=51' into my soldat.ini (I use a dvorak layout so
that's not as retarded as it sounds).
Soldat on Linux: It does work! Need help?

Offline FliesLikeABrick

  • Administrator
  • Flamebow Warrior
  • *****
  • Posts: 6144
    • Ultimate 13 Soldat
Re: Soldat on Linux Systems
« Reply #193 on: May 25, 2007, 03:32:42 pm »
Well, I would tell you to check the AppDB entry on the WINE site, but looks like some dude DELETED Soldat completely off the thing. Not only that, but the other game I maintained, battlefield 2, was deleted as well!! All that hard work...:(

not sure what you're talking about, I see it there

Offline akiross

  • Major(1)
  • Posts: 4
Re: Soldat on Linux Systems
« Reply #194 on: May 25, 2007, 05:33:07 pm »
Ok, thanks 6th_account, really helpful :)

Stealth, yep, but a keyboard scancode may be easy to find... But mouse ones? :) They aren't "just numbers".

Thanks anyway!

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #195 on: May 26, 2007, 10:34:16 am »
They were able to restore it FLAB, fortunately... :)

Bu apparently, the screenshots are gone. If it's possible, can everyone here who voted for Soldat in the WINE poll, please swap your votes from the 1.3.x version to the 1.4.x? I can't submit screenshots of 1.3 anymore since I have 1.4 installed ;P And I can't just swap the votes myself...
« Last Edit: May 26, 2007, 11:04:20 am by Stealth »
Soldat on Linux: It does work! Need help?

Offline Clawbug

  • Veteran
  • *****
  • Posts: 1393
  • 1184!
Re: Soldat on Linux Systems
« Reply #196 on: May 29, 2007, 05:03:09 pm »
Hmm, Is there any way to prevent Ubuntu for using mouse acceleration when using wine? The problem is, that it is rather hard to aim whenever I have to move the mouse quickly, so easy to accidentally overaim. If I set it to zero in Ubuntu, the whole mouse moves SLOWLY all the time, and there is no way to make it move faster. (I haven't really checked the files in /etc/ but I assume that if there was a simple way, it would be in the mouse settings.)

Sounds are a bit glitchy, I don't know why, but they are not played properly, even I am using only ALSA in winecfg.

FPS seems to be quite fine, around 100, and video compatibility fixed the font issue.
Fight! Win! Prevail!

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #197 on: May 29, 2007, 05:51:35 pm »
Looking at this guide, it looks like there's a program that will set it for you (xset), so you'd probably have to make a script for a Soldat shortcut:

Code: [Select]
#!/bin/bash
# Disable mouse acceleration
xset m 0 0
# Start Soldat
wine "C:\Soldat\Soldat.exe"

If sounds are glitchy, you could try OSS, or mess with the settings such as setting the sound to "Standard" or "Emulation" instead of Full, etc. Also lowering sound settings in Soldat's Config program could help.
Soldat on Linux: It does work! Need help?

Offline Clawbug

  • Veteran
  • *****
  • Posts: 1393
  • 1184!
Re: Soldat on Linux Systems
« Reply #198 on: May 30, 2007, 08:53:35 am »
Heh, after playing with the sound configuration and enabled Anistropic filtering, this is what I saw (and where the Soldat hung up..):

http://img402.imageshack.us/img402/6536/soldat14jm5.png

So, ALSA was enabled, so was OSS, bitrate was 22050, 8-bit. Sound quality was minimum in config.exe, anti-aliasing was on. I think I enabled 3 back buffers, which could probably cause this.

Wine is telling me this:
Code: [Select]
fixme:d3d:IWineD3DDeviceImpl_CreateAdditionalSwapChain The app requests more than one back buffer, this can't be supported properly. Please configure the application to use double buffering(=1 back buffer) if possible


Not an issue, I believe, but I found it funny. :P

Edit: I believe it was caued by that I enabled OSS. Playing around with config.exe's sound settings, won't fix the sound issue.

Sounds are also a bit delayed, whenever I shoot, I can hear the sound with a little lag.
Also, it seems that whever I shoot, I lose my weapon, randomly. What I have figured out, is that when I empty my clips of Deagles, the Soldat throws the weapon off. Also, when using jets. and they run out, I it the ground and *boff* I have 100% jets. :o
« Last Edit: May 30, 2007, 01:00:20 pm by Clawbug »
Fight! Win! Prevail!

Offline Stealth

  • Soldier
  • **
  • Posts: 132
    • Just Deserts...
Re: Soldat on Linux Systems
« Reply #199 on: May 31, 2007, 09:25:37 pm »
My sound lags on my laptop as well, I'll try and find a good setting for it...

BTW, you're suppose to have either OSS or ALSA checked, not both. ;P
Soldat on Linux: It does work! Need help?