Author Topic: Can't run polyworks on Windows 7? (dx8vb.dll problem.)  (Read 23594 times)

0 Members and 1 Guest are viewing this topic.

Offline Ithal

  • Major(1)
  • Posts: 7
Can't run polyworks on Windows 7? (dx8vb.dll problem.)
« on: August 29, 2009, 04:06:37 pm »
Hello.

I updated my old Vista to the new (and legal) Windows 7 just today, and everything else is working fine, but just when I try to run soldat polyworks, I get the following error:

Quote
The program can't start because dx8vb.dll is missing from your computer. Try reinstalling the program to fix this problem.

I've googled it, and then I tried this solution to just download that file and dump it into Windows/system32 but it didnt work. (Yes I registered it.)
So, any of you hardcore coders want to help me out here? Im dying to get mapping once again.. :)

Oh and by the way, if it has anything to do with anything, its Windows 7 Ultimate 64-bit.

Thanks, Ithy


UPDATE:
I read the topic in the same forum called "making polyworks work on vista" since windows 7 is basically an update to vista. It didnt work out, I downloaded the dx8vb.dll provided there, and put it in windows/system32, but when I try to run it with regsvr32, it just says something like that dll not found.. I can say the full error message if needed. In the other hand, if I try to type the following into run: "regsvr32 dx8vb.dll" it just says that the dll file is too old or something like that.. Yeah, either one of those didnt work.

UPDATE2:
Got the polyworks working :) Even before anyone could reply.
I just did the same trick as provided in that thread on this forum, but instead of Windows/system32, did it into Windows/SysWOW64 since im running on 64-bit :)


Thanks anyways.
« Last Edit: August 29, 2009, 04:33:10 pm by Ithal »

Offline F4||3N

  • Soldier
  • **
  • Posts: 245
Re: Can't run polyworks on Windows 7? (dx8vb.dll problem.)
« Reply #1 on: August 29, 2009, 07:17:03 pm »
http://forums.soldat.pl/index.php?topic=32041.0

Use command prompt (as administrator). Follow that guide, it should work!

It took me several months to realize what I was doing wrong!


And the recent polyworks update should have fixed the vista problem! (I couldn't find the link)

Offline Ithal

  • Major(1)
  • Posts: 7
Re: Can't run polyworks on Windows 7? (dx8vb.dll problem.)
« Reply #2 on: August 30, 2009, 09:48:52 am »
http://forums.soldat.pl/index.php?topic=32041.0

Use command prompt (as administrator). Follow that guide, it should work!

It took me several months to realize what I was doing wrong!


And the recent polyworks update should have fixed the vista problem! (I couldn't find the link)

Quote
I just did the same trick as provided in that thread on this forum, but instead of Windows/system32, did it into Windows/SysWOW64 since im running on 64-bit :)

Offline F4||3N

  • Soldier
  • **
  • Posts: 245
Re: Can't run polyworks on Windows 7? (dx8vb.dll problem.)
« Reply #3 on: August 30, 2009, 11:58:28 am »
Oh well.

Offline EmilioRylan

  • Major(1)
  • Posts: 1
Re: Can't run polyworks on Windows 7? (dx8vb.dll problem.)
« Reply #4 on: January 04, 2011, 04:35:25 am »
Hello.

I updated my old Vista to the new (and legal) Windows 7 just today, and everything else is working fine, but just when I try to run soldat polyworks, I get the following error:

Quote
The program can't start because dx8vb.dll is missing from your computer. Try reinstalling the program to fix this problem.

hi,

You can go to this site ..
http://www.fix-all-dll-errors.com/dx8vb.dll/

as I registered few dll's 4m dis site ...worked in my problem :)

Offline Phocus

  • Major(1)
  • Posts: 5
  • What to say? <.<
Re: Can't run polyworks on Windows 7? (dx8vb.dll problem.)
« Reply #5 on: March 06, 2011, 02:56:55 pm »
I have Windows 7  64-bit and Ive tried everything on the interwebz. Ive tried registering the files in CMD and it just pops up as "The module "dx8vb.dll" failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files. The specified module could not be found."
Ive tried doing the same for the .oxc files as well and they get the same thing. Ive put them in System32 and in SysWOW64. I'm so comfused and Ive ran polyworks before on my old computer, which was windows 7. And I forgot what I did to make it work  :|  I would love to get back to mapping again. Please reply, thanks.
Who needs Signatures? :P

Offline zakath

  • Inactive Soldat Developer
  • Veteran
  • ******
  • Posts: 1224
    • Soldatladder
Re: Can't run polyworks on Windows 7? (dx8vb.dll problem.)
« Reply #6 on: March 06, 2011, 03:21:49 pm »
I have Windows 7  64-bit and Ive tried everything on the interwebz. Ive tried registering the files in CMD and it just pops up as "The module "dx8vb.dll" failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files. The specified module could not be found."
Ive tried doing the same for the .oxc files as well and they get the same thing. Ive put them in System32 and in SysWOW64. I'm so comfused and Ive ran polyworks before on my old computer, which was windows 7. And I forgot what I did to make it work  :|  I would love to get back to mapping again. Please reply, thanks.

download the installer from http://forums.soldat.pl/index.php?topic=35195.0 and you wont have to register stuff manually.

#soldat.mapping - #soldat.inc - #soldatladder - #soldat.gather.nordic

Offline Phocus

  • Major(1)
  • Posts: 5
  • What to say? <.<
Re: Can't run polyworks on Windows 7? (dx8vb.dll problem.)
« Reply #7 on: March 12, 2011, 07:08:38 pm »
I have Windows 7  64-bit and Ive tried everything on the interwebz. Ive tried registering the files in CMD and it just pops up as "The module "dx8vb.dll" failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files. The specified module could not be found."
Ive tried doing the same for the .oxc files as well and they get the same thing. Ive put them in System32 and in SysWOW64. I'm so comfused and Ive ran polyworks before on my old computer, which was windows 7. And I forgot what I did to make it work  :|  I would love to get back to mapping again. Please reply, thanks.

download the installer from http://forums.soldat.pl/index.php?topic=35195.0 and you wont have to register stuff manually.
You are god and I am stupidity :D
Who needs Signatures? :P

Offline rrrmmm

  • Major(1)
  • Posts: 1
Re: Can't run polyworks on Windows 7? (dx8vb.dll problem.)
« Reply #8 on: December 05, 2011, 12:08:10 pm »
last night i installed this game and trying to play this game .. but got the following dll missing errors.. i have read your full discussion.. But problem is still have....
« Last Edit: December 06, 2011, 05:01:49 am by rrrmmm »

Offline As de Espada

  • Moderator
  • Veteran
  • *****
  • Posts: 1493
  • Mapper
    • My maps
Re: Can't run polyworks on Windows 7? (dx8vb.dll problem.)
« Reply #9 on: December 05, 2011, 02:40:59 pm »
@Ithal: search for the INSTALLER here

last night i installed this game and trying to play this game .. but got the following dll missing errors.. i have read your full discussion.. But problem is still have....
you should make a post here and please write which dlls are missing.
All my maps | my latest map: SoldatX Racing Mappack
me making a map on youtube: ctf_FastMade